DEENESPTFRRUARHIKOZHNL
CLASSIC Modul: eth Rolle: constitutive Konfidenz: 95%

SNIP_CLASSIC_ETH_SECTION_8_3_3_CanXL_GetCounterValues

Quelle: SWS_CANXLDriver.pdf (Seite 23) • Ziel-Anforderung: SWS_Std_00005

Wortlaut

8.3.3 CanXL_GetCounterValues [CP_SWS_CanXL_10005] Definition of API function CanXL_GetCounterValues ⌈ Service Name CanXL_GetCounterValues Syntax Std_ReturnType CanXL_GetCounterValues ( uint8 CtrlIdx, Eth_CounterType* CounterPtr ) Service ID [hex] 0x14 Sync/Async Synchronous Reentrancy Non Reentrant Parameters (in) CtrlIdx Index of the controller within the context of the Driver Parameters (inout) None Parameters (out) CounterPtr counter values according to IETF RFC 1757, RFC 1643 and RFC 2233. Return value Std_ReturnType E_OK: success E_NOT_OK: counter values read failure Description Reads a list with drop counter values of the corresponding controller. The meaning of these values is described at Eth_CounterType. Available via CanXL.h ⌋ Note: This API is derived from Ethernet Driver ([SWS_Eth_00226]). For better understanding of the API’s original intention you may check [8, Ethernet Interface] and [12, Ethernet Driver]. It is called by the AUTOSAR Ethernet Interface to achieve compatible CAN XL agnostic behavior. [CP_SWS_CanXL_00048] ⌈The service CanXL_GetCounterValues() has no functionality and shall always return E_NOT_OK without performing any action.⌋ Specification for CAN XL Driver

Versionen & Provenienz · Zugeordnete Anforderungen

Diese Angaben zeigt der Versions-Explorer.

Begründung & Zuweisungs-Evidenz

Cited verbatim in the snippet (deterministic citation).

Dokumenten-Herkunft & Rückverfolgbarkeit

Spezifikations-Dokument SWS_CANXLDriver.pdf
Dokumentseite Seite 23
Ziel-Modul eth (classic)
Ziel-Anforderung SWS_Std_00005
Semantische Rolle constitutive
Automatisierungs-Konfidenz 0.95