DEENESPTFRRUARHIKOZHNL
CLASSIC Modul: tcpip Rolle: constitutive Konfidenz: 95%

SNIP_CLASSIC_TCPIP_SECTION_7_2_2_Address_Resolution_Protocol_ARP

Quelle: SWS_TcpIp.pdf (Seite 29) • Ziel-Anforderung: SWS_TcpIp_00371

Wortlaut

7.2.2 Address Resolution Protocol (ARP) [SWS_TcpIp_00056] ⌈The TcpIp shall implement the Address Resolution Protocol (ARP) as defined in IETF RFC 826.⌋ [SWS_TcpIp_00090] ⌈The TcpIp shall limit the number of ARP table (address resolution cache) entries to the number specified by the configuration parameter TcpIpArpTableSizeMax.⌋ [SWS_TcpIp_00091] ⌈The TcpIp shall remove entries of the ARP table if they are not used for the timeout specified by the configuration parameter TcpIpArpTableEntryTimeout. If TcpIpArpTableEntryTimeout is set to INF, the TcpIp module shall never remove entries from the ARP table.⌋ [SWS_TcpIp_00092] ⌈If TcpIpArpDefensiveProcessing is set to FALSE, the TcpIp shall use the information from each received IP packet to update the ARP table in addition to received ARP packets.⌋ [SWS_TcpIp_00142] ⌈The TcpIp shall call Up_PhysAddrTableChg() directly after each ARP table change: • If TcpIp adds a new entry or updates an existing one, the parameter valid shall be set to TRUE and the parameters IpAddrPtr and PhysAddrPtr shall be set according to the new or updated entry. • In case TcpIp removes an entry, valid shall be set to FALSE and the parameters IpAddrPtr and PhysAddrPtr shall be set according to the removed entry. ⌋ [SWS_TcpIp_00350] ⌈After the transmission of an ARP request the TcpIp shall skip the transmission of any further ARP requests to the same destination within a duration of TcpIpArpRequestTimeout seconds, according to the mechanism to prevent ARP flooding described in IETF RFC 1122, section 2.3.2.1 ARP Cache Validation.⌋ [SWS_TcpIp_00351] ⌈The TcpIp shall process received ARP packets either directly within the context of the TcpIp_RxIndication() or the first subsequent TcpIp_MainFunction().⌋ [SWS_TcpIp_00093] ⌈On assignment of a new IP address the TcpIp shall send a configurable number (TcpIpArpNumGratuitousARPonStartup) of gratuitous ARP replies according to IETF RFC 2002, section 4.6, second indent. These announcements shall be timed according to IETF RFC 5227 section 2.3. Announcing an Address.⌋ [SWS_TcpIp_00370] Upstream requirements: SRS_Eth_00111 ⌈If TcpIpArpDefensiveProcessing is set to TRUE, the ARP shall silently discard all received ARP packets that have not been requested by a previously transmitted ARP request.⌋ [SWS_TcpIp_00371] Upstream requirements: SRS_Eth_00111 ⌈If TcpIpArpDefensiveProcessing is set to TRUE, the ARP shall skip the update of the ARP table upon processing received Gratuitous ARP packets.⌋

Versionen & Provenienz · Zugeordnete Anforderungen

Diese Angaben zeigt der Versions-Explorer.

Begründung & Zuweisungs-Evidenz

Cited verbatim in the snippet (deterministic citation).

Dokumenten-Herkunft & Rückverfolgbarkeit

Spezifikations-Dokument SWS_TcpIp.pdf
Dokumentseite Seite 29
Ziel-Modul tcpip (classic)
Ziel-Anforderung SWS_TcpIp_00371
Semantische Rolle constitutive
Automatisierungs-Konfidenz 0.95